Help! White looking stuff at the bottom of my tank! - Betta Fish and Betta Fish Care
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 10-15-2011, 11:37 PM Thread Starter
New Member
 
Betta Newbie22's Avatar
 
Join Date: Aug 2011
Location: Indiana
Posts: 80
Help! White looking stuff at the bottom of my tank!

Okay i know i haven't been on here for a while been dealing with finding a job, family problems and everything else.. Anyway Ive had this problem now for a couple months and i just cant figure out how to fix it. So my bf has this 25 gallon tank that he has two green spotted puffers in. Once a month he vacuums it and puts this stuff called Clear water in his tank that breaks up all the food and poop and stuff so it can be sucked up by the filter easier right?. Well my tank was looking a little cloudy so he put some in there to try to clear it up. Well it half worked my water was clearer but the next day there was this white fuzzy stuff at the bottom of the one side of my divided tank. So i vacuumed it out thinking that would take care of it which it got most of it out. but there's still some in there. It doesn't look like its hurting my fish any they seem happy and healthy. My question is How do i get rid of it? I don't wanna use the same stuff to clear up my water is there anything else i can use that will do the same thing but not leave white stuff? Please Help.

Ive Been Bitten By The Betta Bug.
--------------------------------------
My Betta Family<3
*Chaos CT.Male
*Violet VT. Female
*Dante HM. Male

Betta Newbie22 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 10-16-2011, 12:54 AM
Member
 
Pitluvs's Avatar
 
Join Date: Jun 2011
Location: Nova Scotia, Canada
Posts: 2,886
That "clear" stuff should only be used in a cycled tank, is yours cycled? Only thing I can think of is some type of algae or moldy food. Hope someone else see's this and can help you out.


Pitluvs is offline  
post #3 of 5 (permalink) Old 10-16-2011, 01:26 AM Thread Starter
New Member
 
Betta Newbie22's Avatar
 
Join Date: Aug 2011
Location: Indiana
Posts: 80
yeah thats what i was thinking too i just wanna know of a way i can get rid of it.

Ive Been Bitten By The Betta Bug.
--------------------------------------
My Betta Family<3
*Chaos CT.Male
*Violet VT. Female
*Dante HM. Male

Betta Newbie22 is offline  
post #4 of 5 (permalink) Old 10-16-2011, 02:25 PM
Member
 
Silverfang's Avatar
 
Join Date: Mar 2011
Location: Newfoundland
Posts: 2,692
is it fuzzy? or more slimy? If it's slimy it could just be... uh water snot, harmless, but disgusting. If fuzzy I'd be more concerned
Silverfang is offline  
post #5 of 5 (permalink) Old 10-16-2011, 03:22 PM Thread Starter
New Member
 
Betta Newbie22's Avatar
 
Join Date: Aug 2011
Location: Indiana
Posts: 80
its more fuzzy it looks like

Ive Been Bitten By The Betta Bug.
--------------------------------------
My Betta Family<3
*Chaos CT.Male
*Violet VT. Female
*Dante HM. Male

Betta Newbie22 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Betta Fish and Betta Fish Care forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
Powered by vBadvanced CMPS v3.2.3
For the best viewing experience please update your browser to Google Chrome