Why wont they stay alive? - Betta Fish and Betta Fish Care
Reply
 
LinkBack Thread Tools
post #1 of 18 (permalink) Old 09-04-2012, 08:32 PM Thread Starter
Member
 
MistersMom's Avatar
 
Join Date: Aug 2011
Location: Oklahoma
Posts: 2,248
Why wont they stay alive?

Every time i get a pleco or a snail it dies! i had pleco once for a good long time and one day he was dead, i was so mad! i prefer snails because i dont have all the space in the world for the Pleco's but my goodness! what is up with them dying? i have had like 6 of each! i have a really bad algae problem in my tanks, neon green algae and brown algae, and i scrub and scrub and turn my lights off and nothing helps.... so any one know why they could be dying?

<>< MistersMom <><
¸.·´¯`·...¸(><((((º> . .·´¯`·.. >><((((º>
`·.¸¸.·´¯`·(><((((º>
`·.¸¸.·´¯`·
MistersMom is offline  
Sponsored Links
Advertisement
 
post #2 of 18 (permalink) Old 09-04-2012, 09:44 PM
Member
 
thekoimaiden's Avatar
 
Join Date: Oct 2011
Location: Virginia, USA
Posts: 2,450
What kind of snails are you getting? The mystery snails need hard water and need to be fed. They can't just live on algae. It's the ramshorn snails that are the best algae eaters. I've never seen them for sale in a store.

---Izzy

Sitting by the koi pond

writings on fish and fishkeeping


thekoimaiden is offline  
post #3 of 18 (permalink) Old 09-04-2012, 09:47 PM
Member
 
TheCrabbyTabby's Avatar
 
Join Date: Jul 2012
Location: Charlotte, NC
Posts: 474
Water params please. And temp, size of tank ect.

~~~~~~~~~~~~~~~~

“The day the power of love overrules the love of power, the world will know peace.”
Mahatma Gandhi
~~~~~~~~~~~~~~~~
TheCrabbyTabby is offline  
post #4 of 18 (permalink) Old 09-04-2012, 09:52 PM
Member
 
djembekah's Avatar
 
Join Date: Feb 2012
Location: Washington
Posts: 1,108
and what kind of pleco have you been buying? commons need practically 75gallons to themselves

~bekah
i like fish and piercings and yarn
http://freshwaterfish.tumblr.com
i <3 snails
55 gallon planted journal

ukuleles djembes and happiness
djembekah is offline  
post #5 of 18 (permalink) Old 09-05-2012, 09:30 AM Thread Starter
Member
 
MistersMom's Avatar
 
Join Date: Aug 2011
Location: Oklahoma
Posts: 2,248
uhm, water is normal betta water? 80 degrees i guess... i havent had one in a long time (snail pleco) i just want to know why they keep passing. can AQ salt kill them? and i dont know what kind if snails they are....

<>< MistersMom <><
¸.·´¯`·...¸(><((((º> . .·´¯`·.. >><((((º>
`·.¸¸.·´¯`·(><((((º>
`·.¸¸.·´¯`·
MistersMom is offline  
post #6 of 18 (permalink) Old 09-05-2012, 10:58 AM
Member
 
Jupiter's Avatar
 
Join Date: Aug 2009
Location: Ontario
Posts: 4,158
How big is the tank? Is it filtered? What exactly is "normal betta water"? Do you mean you use those bottled "betta water" things?

I don't remember exactly but i think AQ salt doesn't sit well with scaleless fish as well as snails.


Puck (Yellow koi HM king) / Scar (White HM) / Salt 'n Pepper (Silver HMPK) / 'That fish' (Copper butterfly HM) / No name (White DT) / No name 2 (Turquoise/white marble HM) / No name 3 (Lilac HM)




Bo Peep (Cambodian VT) / Goldilocks (Yellow VT) / Joie de Vivre (Multicolour VT) / Lil' Peep (Blue VT) / No name (Dalmatian VT) / No name 2

Last edited by Jupiter; 09-05-2012 at 11:01 AM.
Jupiter is offline  
post #7 of 18 (permalink) Old 09-05-2012, 11:07 AM
Member
 
megaredize's Avatar
 
Join Date: May 2012
Location: Ontario Canada
Posts: 686
ya salt plus snail is death, and it does say on the salt packaging to be careful with scaleless fish. like mentioned they need to be fed also cant live just on algae
megaredize is offline  
post #8 of 18 (permalink) Old 09-05-2012, 11:34 AM
Member
 
Coppermoon's Avatar
 
Join Date: May 2012
Posts: 188
Pleco's don't "eat algae", they eat a specific algae. The have to be fed wafers.
I have Rams snails, pond snails, an apple snail, mystery snails (trapdoor less) and MTS. My tanks have 1tsp for 1g or 1 TBSP for 5g (according to if I mix up 15g of water at a time, then I use the 1 TBSP). All snails are fine....anyone need MTS...I'm overrun!!!

Are you sure you have algae? There are several "algae" that are not algae at all, it is bacteria/fungus. Each algae eater eats specific type of algae.

Betta Breeder 2006, Showing Betta 2008
Member of IBC, President of Lone Star Bettas
Overacoppermoon.com, lonestarbettas.com
Hi my name is Lori and I'm a Betta Addict...
Coppermoon is offline  
post #9 of 18 (permalink) Old 09-05-2012, 04:56 PM Thread Starter
Member
 
MistersMom's Avatar
 
Join Date: Aug 2011
Location: Oklahoma
Posts: 2,248
yes i had algae wafers too and dropped them in there. and the algae is brown and green, i dont what it is D: wonna send me some MTS lol. jk , its a death wish lol.and nooo not betta water i mean its fine the perameters are fine, i dont have any testing things atm but i take it to class ans test it, is soft water. not slaty but i do add salt. and even then it soft... i don't know....

<>< MistersMom <><
¸.·´¯`·...¸(><((((º> . .·´¯`·.. >><((((º>
`·.¸¸.·´¯`·(><((((º>
`·.¸¸.·´¯`·
MistersMom is offline  
post #10 of 18 (permalink) Old 09-05-2012, 05:07 PM
Mo
Member
 
Mo's Avatar
 
Join Date: Mar 2012
Posts: 4,667
How large is the tank and what type of Pleco have you been purchasing, what have you been feeding it,

Mo is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Betta Fish and Betta Fish Care forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
Powered by vBadvanced CMPS v3.2.3
For the best viewing experience please update your browser to Google Chrome