Bugs on my plants. - Betta Fish and Betta Fish Care
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 04-04-2013, 05:27 PM Thread Starter
New Member
 
Join Date: Feb 2012
Posts: 18
Bugs on my plants.

Sorry if this isnt the right place for this thread, it can be moved if it's not ;u;

I did a water change yesterday and noticed these super tiny black dots everywhere on my plants. At first I thought they were fish poo or algae but a closer look at them and they were slowly moving. They weren't there just a week before in my last water change i think and nothing new has been added to the tank (I added the live plants about four weeks ago that was the most recent addition to the tank.)

They arent on top of the water or swimming around in the water just on the plants under the water and a few in the substrate. Ive looked through all kinds of information on tank pests and this doesnt look like anything ive found info on.

I'm worried about my betta. He rests on the plant leaves lots and I dont want the bugs to get on him and possible harm him cause he seems a bit distressed.

I dont think I'm overfeeding either I only give him a little pinch of flakes every other day.

Tried my best to get a picture of the little buggers.




When i did the water change I toke out the bubbling decoration cause it was broke, scrubbed the algae off it and set it by my bathroom sink to dry. Found the little buggers all over the thing the bubbler was sitting on this morning.




Does anyone know what they are? If they're harmless and will go away on their own? They appeared so suddenly.
TopHatViolet is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 04-04-2013, 06:41 PM
Member
 
Otterfun's Avatar
 
Join Date: Dec 2012
Posts: 1,128
could be pond snails, do you have live plants that you have not QTed?

Thanks
Otterfun is offline  
post #3 of 4 (permalink) Old 04-04-2013, 08:52 PM Thread Starter
New Member
 
Join Date: Feb 2012
Posts: 18
Dont think they are pond snails, with a magnifying glass I can just make out little legs on them. Also I didnt QT my plants before I put them in 8'D whatever these things are though they toke over a month to show up from when I put the plants in though?
TopHatViolet is offline  
post #4 of 4 (permalink) Old 04-04-2013, 09:01 PM
Member
 
Join Date: Jan 2013
Posts: 294
Ostracods, maybe scuds or clamshrimp...thats all I can really think of.
Naladari is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Betta Fish and Betta Fish Care forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Bugs??? emeraldmaster Planted Betta Tanks 5 01-03-2013 08:33 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
Powered by vBadvanced CMPS v3.2.3
For the best viewing experience please update your browser to Google Chrome