Cloudiness in an established tank? - Betta Fish and Betta Fish Care
Reply
 
LinkBack Thread Tools
post #1 of 24 (permalink) Old 05-01-2013, 11:28 PM Thread Starter
Member
 
lilyth88's Avatar
 
Join Date: Mar 2012
Location: Wisconsin
Posts: 782
Cloudiness in an established tank?

So both of my NPTs are completely cloudy. It came on suddenly. They've been set up for awhile, and I'm not sure what's going on. I did some water changes to try and clear it up, but it only helps a little and then it gets cloudy again. Any thoughts?
lilyth88 is offline  
Sponsored Links
Advertisement
 
post #2 of 24 (permalink) Old 05-02-2013, 12:43 AM
Member
 
Kithy's Avatar
 
Join Date: Nov 2012
Location: Dallas, TX
Posts: 1,563
Did you add in any more fish? Sometimes that can cause a mini cycle and maybe a bacteria bloom.
Kithy is offline  
post #3 of 24 (permalink) Old 05-02-2013, 04:35 PM
Member
 
jessp118's Avatar
 
Join Date: Dec 2012
Location: USA, Massachusetts
Posts: 155
Sounds like a bacteria bloom. it will clear up in a few days.
jessp118 is offline  
post #4 of 24 (permalink) Old 05-02-2013, 05:17 PM
Member
 
Kithy's Avatar
 
Join Date: Nov 2012
Location: Dallas, TX
Posts: 1,563
Have you checked the parameters? Are there fish in or not? Filter? How long has the tank been set up?
Kithy is offline  
post #5 of 24 (permalink) Old 05-02-2013, 06:29 PM
Member
 
rmarkham's Avatar
 
Join Date: Oct 2012
Location: Malden, MA
Posts: 742
I had a bacterial bloom after my planted tank had been set up for about 2 years. I had done a large water change and then BOOM... cloudy hell!

My ammonia spiked at .25ppm but I did another water change and it corrected itself.

40G planted community
3 5G planted betta tank

Last edited by ao; 05-02-2013 at 07:45 PM.
rmarkham is offline  
post #6 of 24 (permalink) Old 05-03-2013, 11:27 AM Thread Starter
Member
 
lilyth88's Avatar
 
Join Date: Mar 2012
Location: Wisconsin
Posts: 782
Quote:
Originally Posted by Kithy View Post
Did you add in any more fish? Sometimes that can cause a mini cycle and maybe a bacteria bloom.
I did not. It has happened in both NPTs, one more than the other. One of them has 4 Amano Shrimp, 1 Nerite Snail, and my betta. It is 5 gallons. The other has 5 Amano Shrimp, 1 Nerite Snail, and my betta.

Quote:
Originally Posted by jessp118 View Post
Sounds like a bacteria bloom. it will clear up in a few days.
It has been like this for a week and a half despite doing multiple water changes.

Quote:
Originally Posted by Kithy View Post
Have you checked the parameters? Are there fish in or not? Filter? How long has the tank been set up?
I have checked the ammonia, which is fine. See my above statement on the livestock. The tanks have been set up since March.
Edit: Forgot to answer your filter question. There are sponge filters in both tanks.

Quote:
Originally Posted by rmarkham View Post
I had a bacterial bloom after my planted tank had been set up for about 2 years. I had done a large water change and then BOOM... cloudy hell!

My ammonia spiked at .25ppm but I did another water change and it corrected itself.
My ammonia has been fine. I've done multiple water changes in both tanks and while it clears up some cloudiness, it just comes back.
lilyth88 is offline  
post #7 of 24 (permalink) Old 05-03-2013, 02:25 PM
Member
 
Kithy's Avatar
 
Join Date: Nov 2012
Location: Dallas, TX
Posts: 1,563
If only set up since March it could still be cycling a bit. The cloudiness in my tank during cycle lasted almost two weeks before suddenly clearing up.

If the fish are fine and parameters are okay I just can't think of what it could be. I'm sure you're frustrated :<
Kithy is offline  
post #8 of 24 (permalink) Old 05-03-2013, 02:25 PM Thread Starter
Member
 
lilyth88's Avatar
 
Join Date: Mar 2012
Location: Wisconsin
Posts: 782
Quote:
Originally Posted by Kithy View Post
If only set up since March it could still be cycling a bit. The cloudiness in my tank during cycle lasted almost two weeks before suddenly clearing up.

If the fish are fine and parameters are okay I just can't think of what it could be. I'm sure you're frustrated :<
Why would it be fine from March until now and just suddenly do this though? =(
lilyth88 is offline  
post #9 of 24 (permalink) Old 05-03-2013, 02:36 PM
Member
 
Stone's Avatar
 
Join Date: Jan 2013
Posts: 1,195
Well I just recently had an issue with my 46 gal npt and it was one 3 fronts, I had done a major canister filter cleaning cleaned out all the lines and well everything in a bucket of tank water, and I had added a wave maker in my tank between those 2 things I was in cloudy hell with a bac bloom from the filter re-estabishing and the current from the wave maker blowing apart the algae discs for the corys and pleco and a bit of leaving the light on too long, sometimes it is just not one reason think about any and all changes that might have been made
Stone is offline  
post #10 of 24 (permalink) Old 05-03-2013, 02:45 PM Thread Starter
Member
 
lilyth88's Avatar
 
Join Date: Mar 2012
Location: Wisconsin
Posts: 782
Quote:
Originally Posted by Stone View Post
Well I just recently had an issue with my 46 gal npt and it was one 3 fronts, I had done a major canister filter cleaning cleaned out all the lines and well everything in a bucket of tank water, and I had added a wave maker in my tank between those 2 things I was in cloudy hell with a bac bloom from the filter re-estabishing and the current from the wave maker blowing apart the algae discs for the corys and pleco and a bit of leaving the light on too long, sometimes it is just not one reason think about any and all changes that might have been made

There was literally no changes to the tank. Nothing new was added and nothing was taken away.
lilyth88 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Betta Fish and Betta Fish Care forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
Powered by vBadvanced CMPS v3.2.3
For the best viewing experience please update your browser to Google Chrome