Filter Not Working ??? - Betta Fish and Betta Fish Care
Like Tree2Likes
  • 1 Post By CrazyDiamond
  • 1 Post By CrazyDiamond
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 01-15-2014, 01:33 PM Thread Starter
Member
 
CrazyDiamond's Avatar
 
Join Date: Feb 2013
Location: NC
Posts: 180
Filter Not Working ???

It's a Whisper 10i that came with the tank so it's 13 months old but here lately I've had trouble getting it to start back up after I have unplugged it in order to clean the tank. At first it was just taking a long time to start back up, then it wouldn't start back up at all unless I took it out, disassembled and cleaned it out real well then plugged it back in. But now as I sit here it has been about an hour since I plugged it in after cleaning it and still nothing. I guess it's just not going to come back on :(

I don't have any disposable income (in fact I have NO income) so I really want to weigh my options before replacing this filter.

-I have a mature NPT it's cycled, my plants are flourishing all the levels are where they need to be.

-I read somewhere that once you get the tank mature and everything a filter is really not even necessary. Is this true?

-If so will I need to clean more often if I decide to go the filterless route?

"Shine on you crazy diamond." -Pink Floyd
RIP Floyd & Fred
CrazyDiamond is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 01-15-2014, 03:09 PM
Member
 
rsskylight04's Avatar
 
Join Date: Nov 2013
Location: Syracuse, New York, USA
Posts: 151
Love your user name and fishes names in your signature line! I'm a child of the 70s and still love all the great music from then. Somtimes filter parts can become encrusted with calcium deposits and have a hard time starting. Try soaking the filter in white vinegar to disolve the calcium, just be very carful to rinse it thoroughly. Do not leave the filter plugged in if it is not running ... it will burn out the motor.
I always use filters, but if you don't have many fish and don't feed a lot I guess you coul get away without one... maybe just till you save to get another? I would reccommend twice weekly water changes of 25% and water testing till you find out what your tank is doing.
Best of luck to you and Shine On , You Crazy Diamond!

"Be the change you want to see in the world."
rsskylight04 is offline  
post #3 of 4 (permalink) Old 01-15-2014, 05:05 PM Thread Starter
Member
 
CrazyDiamond's Avatar
 
Join Date: Feb 2013
Location: NC
Posts: 180
Omg we would get along just fine xD I wish I was a 70s kid but I am a 90s, born in '89 but I love 70s music!
I have unplugged my filter! I can soak it tomorrow I have schoolwork to do right now unfortunately but atm I have one fish in that tank and a snail, I've noticed the snail poops a lot xD but she/he keeps the algae down so i don't mind.
rsskylight04 likes this.

"Shine on you crazy diamond." -Pink Floyd
RIP Floyd & Fred
CrazyDiamond is offline  
post #4 of 4 (permalink) Old 01-26-2014, 03:12 PM Thread Starter
Member
 
CrazyDiamond's Avatar
 
Join Date: Feb 2013
Location: NC
Posts: 180
I finally got around to fixing it! The vinegar totally worked, thank you!!!
rsskylight04 likes this.

"Shine on you crazy diamond." -Pink Floyd
RIP Floyd & Fred
CrazyDiamond is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Betta Fish and Betta Fish Care forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
Powered by vBadvanced CMPS v3.2.3
For the best viewing experience please update your browser to Google Chrome