Betta Fish Care  
Go Back   Betta Fish and Betta Fish Care > Betta Fish Care
Check out the eBook Betta Fish Care Made Easy
betta fish
Reply
 
Thread Tools Search this Thread
Old 08-01-2012, 09:41 AM   #11 
Bettanewbie60
Member
 
Bettanewbie60's Avatar
 
Join Date: Jun 2012
Location: Coastal Georgia
Quote:
Originally Posted by Unity View Post
Which filter is it?
It's a Whisper Micro Filter. It came with Buddy's 5g marineland tank, but I used a smaller Tetra whisper 1-3 for it, so when I bought the glass 5.5 I put the larger filter in there. It doesn't seem to be vibrating as badly, but I'm still going to do a good cleaning on it tomorrow when I do water changes.
Bettanewbie60 is offline   Reply With Quote
Old 08-01-2012, 10:08 AM   #12 
Unity
New Member
 
Unity's Avatar
 
Join Date: Mar 2012
Location: Saratoga Springs, NY
I have found those in-tank whispers to be phenomenal filters (as long they are the adjustable ones and at their lowest setting).

One piece of (perhaps obvious) advice with those is to make sure the suction cup is firmly in place. That might solve the problem!

Good luck!
Unity is offline   Reply With Quote
Old 08-01-2012, 10:13 AM   #13 
Bettanewbie60
Member
 
Bettanewbie60's Avatar
 
Join Date: Jun 2012
Location: Coastal Georgia
Quote:
Originally Posted by Unity View Post
I have found those in-tank whispers to be phenomenal filters (as long they are the adjustable ones and at their lowest setting).

One piece of (perhaps obvious) advice with those is to make sure the suction cup is firmly in place. That might solve the problem!

Good luck!
Thanks...yeah, when I inspected it the other night the motor itself was not tight in it's place, so that was the issue. Thanks for your help!
Bettanewbie60 is offline   Reply With Quote
Old 08-01-2012, 10:15 AM   #14 
clopez1
Member
 
clopez1's Avatar
 
Join Date: May 2012
Location: Miramar, Fl.
I knew it had to be the motor or propeller, my HOB had the same issue, adjusted the intake tube and the propeller went in flush, problem solved.
clopez1 is offline   Reply With Quote
Old 08-01-2012, 02:54 PM   #15 
Unity
New Member
 
Unity's Avatar
 
Join Date: Mar 2012
Location: Saratoga Springs, NY
Ah - well as I am sure you know now, if there is no water spilling off the top of the filter then there is almost definitely a problem with the connection between the power unit and filter unit :) Glad it worked out! That is a great filter.
Unity is offline   Reply With Quote
Old 08-01-2012, 06:22 PM   #16 
Bettanewbie60
Member
 
Bettanewbie60's Avatar
 
Join Date: Jun 2012
Location: Coastal Georgia
Quote:
Originally Posted by Unity View Post
Ah - well as I am sure you know now, if there is no water spilling off the top of the filter then there is almost definitely a problem with the connection between the power unit and filter unit :) Glad it worked out! That is a great filter.
Yeah...thanks for all the help everyone! Live and learn!
Bettanewbie60 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Loud, shocking vibration tennisgirl858 Betta Fish Diseases and Emergencies 6 09-20-2010 01:32 PM
2.5 minibow filter tore tailfin, need advice putting in Red Sea filter ASAP KristiLee Betta Fish Bowls, Habitats, and Accessories 1 01-09-2010 07:58 PM
Nylons on filter intake? Filter changes? and Prime for cycled tanks? PinkDiamond Betta Fish Bowls, Habitats, and Accessories 9 09-04-2009 05:36 PM


All times are GMT -5. The time now is 02:41 PM.


Powered by vBulletin® Version 3.7.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.