Betta Fish Care  
Go Back   Betta Fish and Betta Fish Care > Betta Fish Care
Check out the eBook Betta Fish Care Made Easy
betta fish
Reply
 
Thread Tools Search this Thread
Old 09-14-2010, 05:01 PM   #11 
Ajones108
Member
 
Ajones108's Avatar
 
Join Date: Jul 2010
Location: Tampa, FL
If your body temperature is 98 degrees and your water feels warm to the touch, I would be slightly concerned. It would feel different to everyone though.. I recommend putting the glass thermometer in and letting it run 24 hours.
Ajones108 is offline   Reply With Quote
Old 09-14-2010, 05:02 PM   #12 
MamaKat
New Member
 
MamaKat's Avatar
 
Join Date: Sep 2010
Location: Central IA
No I mean the heater never felt warm.
MamaKat is offline   Reply With Quote
Old 09-14-2010, 07:44 PM   #13 
Ajones108
Member
 
Ajones108's Avatar
 
Join Date: Jul 2010
Location: Tampa, FL
Sometimes it's the angle of the heater that keeps it from clicking on, or the water level being too low. I had that problem with my heater once. I just unplugged it, shook any water out, put it back in the tank completely submerged and vertical, plugged it back in, and eventually the tank heated.
Ajones108 is offline   Reply With Quote
Old 09-14-2010, 08:00 PM   #14 
MamaKat
New Member
 
MamaKat's Avatar
 
Join Date: Sep 2010
Location: Central IA
Hmm. We shall see if my husband was able to return/exchange it or not. If not I'll try it again. This is the first time I've ever used a heater. Growing up with my 10 gallon we never used heaters with our tropical fish. I didn't with my 2.5 gallon either. Just had the light and filter system.
MamaKat is offline   Reply With Quote
Old 09-14-2010, 08:04 PM   #15 
Ajones108
Member
 
Ajones108's Avatar
 
Join Date: Jul 2010
Location: Tampa, FL
Most people here can put in a good word for the Hydor Theo heaters.
Ajones108 is offline   Reply With Quote
Old 09-14-2010, 08:43 PM   #16 
MamaKat
New Member
 
MamaKat's Avatar
 
Join Date: Sep 2010
Location: Central IA
Thanks!
MamaKat is offline   Reply With Quote
Old 09-15-2010, 10:17 AM   #17 
CodeRed
Member
 
CodeRed's Avatar
 
Join Date: Jun 2009
Location: USofA
Welcome to the forum! ^_^ We all adore pictures, so don't be afraid to put any up, if you haven't already. And if you're anything like me, feel free to CONTINUE posting pictures xD Feel free to ask questions, of course, as it's what we're here for! (:
Andd... looking now, you have posted pictures! I'll go comment there :D Once again, welcome to our humble site!
CodeRed is offline   Reply With Quote
Old 09-15-2010, 01:04 PM   #18 
MamaKat
New Member
 
MamaKat's Avatar
 
Join Date: Sep 2010
Location: Central IA
Looks like my thermometer is finally working. Its green right over the 80. Orange on the 82 and blue on the 78. I think that means its working since I had no color yesterday. Still plan to get a more reliable thermometer.
MamaKat is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:51 AM.


Powered by vBulletin® Version 3.7.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.