Betta Fish Care  
Go Back   Betta Fish and Betta Fish Care > Planted Betta Tanks
Check out the eBook Betta Fish Care Made Easy
betta fish
Reply
 
Thread Tools Search this Thread
Old 05-01-2013, 11:28 PM   #1 
lilyth88
Member
 
lilyth88's Avatar
 
Join Date: Mar 2012
Location: Wisconsin
Cloudiness in an established tank?

So both of my NPTs are completely cloudy. It came on suddenly. They've been set up for awhile, and I'm not sure what's going on. I did some water changes to try and clear it up, but it only helps a little and then it gets cloudy again. Any thoughts?
lilyth88 is offline   Reply With Quote
Old 05-02-2013, 12:43 AM   #2 
Kithy
Member
 
Kithy's Avatar
 
Join Date: Nov 2012
Location: Dallas, TX
Did you add in any more fish? Sometimes that can cause a mini cycle and maybe a bacteria bloom.
Kithy is offline   Reply With Quote
Old 05-02-2013, 04:35 PM   #3 
jessp118
Member
 
jessp118's Avatar
 
Join Date: Dec 2012
Location: USA, Massachusetts
Sounds like a bacteria bloom. it will clear up in a few days.
jessp118 is offline   Reply With Quote
Old 05-02-2013, 05:17 PM   #4 
Kithy
Member
 
Kithy's Avatar
 
Join Date: Nov 2012
Location: Dallas, TX
Have you checked the parameters? Are there fish in or not? Filter? How long has the tank been set up?
Kithy is offline   Reply With Quote
Old 05-02-2013, 06:29 PM   #5 
rmarkham
Member
 
rmarkham's Avatar
 
Join Date: Oct 2012
Location: Malden, MA
I had a bacterial bloom after my planted tank had been set up for about 2 years. I had done a large water change and then BOOM... cloudy hell!

My ammonia spiked at .25ppm but I did another water change and it corrected itself.

Last edited by ao; 05-02-2013 at 07:45 PM.
rmarkham is offline   Reply With Quote
Old 05-03-2013, 11:27 AM   #6 
lilyth88
Member
 
lilyth88's Avatar
 
Join Date: Mar 2012
Location: Wisconsin
Quote:
Originally Posted by Kithy View Post
Did you add in any more fish? Sometimes that can cause a mini cycle and maybe a bacteria bloom.
I did not. It has happened in both NPTs, one more than the other. One of them has 4 Amano Shrimp, 1 Nerite Snail, and my betta. It is 5 gallons. The other has 5 Amano Shrimp, 1 Nerite Snail, and my betta.

Quote:
Originally Posted by jessp118 View Post
Sounds like a bacteria bloom. it will clear up in a few days.
It has been like this for a week and a half despite doing multiple water changes.

Quote:
Originally Posted by Kithy View Post
Have you checked the parameters? Are there fish in or not? Filter? How long has the tank been set up?
I have checked the ammonia, which is fine. See my above statement on the livestock. The tanks have been set up since March.
Edit: Forgot to answer your filter question. There are sponge filters in both tanks.

Quote:
Originally Posted by rmarkham View Post
I had a bacterial bloom after my planted tank had been set up for about 2 years. I had done a large water change and then BOOM... cloudy hell!

My ammonia spiked at .25ppm but I did another water change and it corrected itself.
My ammonia has been fine. I've done multiple water changes in both tanks and while it clears up some cloudiness, it just comes back.
lilyth88 is offline   Reply With Quote
Old 05-03-2013, 02:25 PM   #7 
Kithy
Member
 
Kithy's Avatar
 
Join Date: Nov 2012
Location: Dallas, TX
If only set up since March it could still be cycling a bit. The cloudiness in my tank during cycle lasted almost two weeks before suddenly clearing up.

If the fish are fine and parameters are okay I just can't think of what it could be. I'm sure you're frustrated :<
Kithy is offline   Reply With Quote
Old 05-03-2013, 02:25 PM   #8 
lilyth88
Member
 
lilyth88's Avatar
 
Join Date: Mar 2012
Location: Wisconsin
Quote:
Originally Posted by Kithy View Post
If only set up since March it could still be cycling a bit. The cloudiness in my tank during cycle lasted almost two weeks before suddenly clearing up.

If the fish are fine and parameters are okay I just can't think of what it could be. I'm sure you're frustrated :<
Why would it be fine from March until now and just suddenly do this though? =(
lilyth88 is offline   Reply With Quote
Old 05-03-2013, 02:36 PM   #9 
Stone
Member
 
Stone's Avatar
 
Join Date: Jan 2013
Well I just recently had an issue with my 46 gal npt and it was one 3 fronts, I had done a major canister filter cleaning cleaned out all the lines and well everything in a bucket of tank water, and I had added a wave maker in my tank between those 2 things I was in cloudy hell with a bac bloom from the filter re-estabishing and the current from the wave maker blowing apart the algae discs for the corys and pleco and a bit of leaving the light on too long, sometimes it is just not one reason think about any and all changes that might have been made
Stone is offline   Reply With Quote
Old 05-03-2013, 02:45 PM   #10 
lilyth88
Member
 
lilyth88's Avatar
 
Join Date: Mar 2012
Location: Wisconsin
Quote:
Originally Posted by Stone View Post
Well I just recently had an issue with my 46 gal npt and it was one 3 fronts, I had done a major canister filter cleaning cleaned out all the lines and well everything in a bucket of tank water, and I had added a wave maker in my tank between those 2 things I was in cloudy hell with a bac bloom from the filter re-estabishing and the current from the wave maker blowing apart the algae discs for the corys and pleco and a bit of leaving the light on too long, sometimes it is just not one reason think about any and all changes that might have been made

There was literally no changes to the tank. Nothing new was added and nothing was taken away.
lilyth88 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Moving with an established tank? Wolfstardobe Betta Fish Care 2 12-17-2011 10:28 AM


All times are GMT -5. The time now is 09:29 PM.


Powered by vBulletin® Version 3.7.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.