Betta Fish Care  
Go Back   Betta Fish and Betta Fish Care > Betta Fish Bowls, Habitats, and Accessories
Check out the eBook Betta Fish Care Made Easy
betta fish
Reply
 
Thread Tools Search this Thread
Old 08-31-2013, 12:08 PM   #1 
Sugarbeet
Member
 
Join Date: Feb 2013
Dead filter

So, my Whisper 40 started making a weird grinding noise a few minutes ago, and now appears to be dead. I tried opening the valve while it was making that noise, thinking that with the flow turned all the way down maybe the pump was straining, but that might have made it worse. The reservoir bit emptied itself and the motor stopped.

What the hell? I haven't even had this filter six months yet. The crappy internal that came with my 5g tank last year is still chugging merrily away, but this one's decided it's had enough on one of the hottest days of the summer. >:[

Is there anything I can do to fix it? I've got it unplugged now, just in case.

If it's dead for good, does anyone have suggestions for an affordable, reliable filter for a 20g?
Sugarbeet is offline   Reply With Quote
Old 08-31-2013, 12:09 PM   #2 
MattsBettas
Reference Team
 
MattsBettas's Avatar
 
Join Date: Dec 2012
Location: Alberta, Canada
Let it cool down, remove the cartridges and leave them in tank water, then clean the pump out with a qtip. See if that helps. Do you use sand as substrate?
MattsBettas is offline   Reply With Quote
Old 08-31-2013, 12:24 PM   #3 
Sugarbeet
Member
 
Join Date: Feb 2013
Okay, so false alarm. After about five minutes of jiggling the intake around, it seems to be working again. Whoops. :v
Sugarbeet is offline   Reply With Quote
Old 08-31-2013, 12:28 PM   #4 
Sugarbeet
Member
 
Join Date: Feb 2013
Yeah, I use sand. There's a good six or seven inches' worth of clearance between the sand and the intake, but it's possible enough got in there to clog up the propeller or something. Something must have gotten up in there, and I didn't find any bits of leaves.

I think I'll give it a proper cleaning like you described once the weather cools down a bit. I don't like the thought of not having a current for any length of time when it's this hot.
Sugarbeet is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Bettas sucked into filter. 2 dead, 4 injured. RnB Betta Fish Diseases and Emergencies 8 06-14-2012 09:20 PM
Dead Filter JLovesBettas Betta Fish Bowls, Habitats, and Accessories 5 02-02-2011 04:48 PM


All times are GMT -5. The time now is 02:51 AM.


Powered by vBulletin® Version 3.7.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.