Betta Fish Care  
Go Back   Betta Fish and Betta Fish Care > Betta Fish Bowls, Habitats, and Accessories
Check out the eBook Betta Fish Care Made Easy
betta fish
Reply
 
Thread Tools Search this Thread
Old 11-15-2009, 10:24 AM   #1 
azjen
New Member
 
azjen's Avatar
 
Join Date: Sep 2009
Is my heater working?

I got a new 10 gallon tank that comes with a heater. It is a tetra 50 watt heater with a suction cup. I put horizontally at the bottom along the water line and plugged it in but it does not seem to have made a difference 10 hours later. Should the heater itself feel warm at all because mine doesn't?

The website says it can take 36 hours but I would think the heater would feel a little warm if it was heating the water.

Thanks!

Jennine
azjen is offline   Reply With Quote
Old 11-15-2009, 11:24 AM   #2 
Jupiter
Member
 
Jupiter's Avatar
 
Join Date: Aug 2009
Location: Ontario
Tetra filters, I've found, don't work well at all. I wouldn't reccomend them.
Jupiter is offline   Reply With Quote
Old 11-15-2009, 11:32 AM   #3 
azjen
New Member
 
azjen's Avatar
 
Join Date: Sep 2009
Dang! It came with my aquarium and since my water is normally about 74 anyway, I hoped it could do the job to just heat it a few degrees. I did not think that is asking much - even for a cruddy heater!

Does it sound defective? Should it feel slightly warm when I touch the tubing? If so, I will return it and have them give me another one.
azjen is offline   Reply With Quote
Old 11-15-2009, 11:45 AM   #4 
Jupiter
Member
 
Jupiter's Avatar
 
Join Date: Aug 2009
Location: Ontario
Do you have a thermometer in your tank? It's not heating it at all?
Jupiter is offline   Reply With Quote
Old 11-15-2009, 12:56 PM   #5 
azjen
New Member
 
azjen's Avatar
 
Join Date: Sep 2009
It is hard to tell. I just put in a thermometer. To me, it feels a little cooler than last night because when I put the tap water in, I put in some that was a little warm at the end to try to speed up the process of heating it. This morning, it feels the same or a little cooler.

My question though is if it is in heat mode, will the actual heater feel a little warm to the touch? Mine does not at all which makes me assume it is doing nothing.
azjen is offline   Reply With Quote
Old 11-15-2009, 01:27 PM   #6 
Ender
New Member
 
Ender's Avatar
 
Join Date: Nov 2009
Location: Boone, NC
Mine does not feel warm. You really need to get a thermometer (only $2). Touch won't be of much help. 78F (which is what the Tetra heaters are set at) water feels quite cool on 98F skin.

Be sure to not turn the heater on unless it is submerged. You can irreparably damage it.
Ender is offline   Reply With Quote
Old 11-15-2009, 01:53 PM   #7 
azjen
New Member
 
azjen's Avatar
 
Join Date: Sep 2009
I did put the thermometer from my other tank in there to check and it is running about 76 degrees in there. A red light went on the heater for about 5 minutes then went off again so that means it was heating it for a few moments at least.

I am off to get a few things at the pet store and will grab a few more thermometers.

I went and bought my boys a betta yesterday and fell in love with a white one and so now I need to buy another tank and such for MY betta.

I was just trying to assess if this heater was working and such before heading to the store since my boy's betta will be alone in a 10 gallon tank and I did not want it to be too cold in there when I put him in.

I hadn't needed a heater in my girls betta tank yet since the water was staying at 76-78 degrees but with it getting a little cooler out with the weather cooling, I think I am going to go ahead and grab a little heater for it anyway so it doesn't get too cool in there.

thanks for your help with this! I will have to post a pic of the boys tank later. It is a gorgeous tank that they picked out...
azjen is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
It's working! CodeRed Betta Fish Diseases and Emergencies 4 12-03-2009 09:05 AM
Heater not working. TianTian Betta Fish Care 2 12-01-2009 04:02 PM


All times are GMT -5. The time now is 06:52 AM.


Powered by vBulletin® Version 3.7.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.