Betta Fish Care  
Go Back   Betta Fish and Betta Fish Care > Betta Fish Bowls, Habitats, and Accessories
Check out the eBook Betta Fish Care Made Easy
betta fish
Reply
 
Thread Tools Search this Thread
Old 06-12-2010, 03:13 PM   #1 
Welsh
Member
 
Welsh's Avatar
 
Join Date: Apr 2010
Location: South Wales, UK
I really dont know what just happened

So for you those of you who haven't read my thread I bought a new tank yesterday, I set it up as the LFS told me (which I already knew) and added the fish, today 3 of the new fish have died I tested the water and everything is at 0 the only thing that I can think of that killed them is that the filter was too strong but I blocked the hole where the water comes out of and stabbed holes, so I just dont know what happened.
Welsh is offline   Reply With Quote
Old 06-12-2010, 03:59 PM   #2 
Oldfishlady
Member
 
Join Date: Mar 2010
Location: USA
Sorry, I must have missed your new tank thread, what size is it and what kind of fish died?
Oldfishlady is offline   Reply With Quote
Old 06-12-2010, 04:12 PM   #3 
vaygirl
Member
 
vaygirl's Avatar
 
Join Date: Sep 2009
Location: Middlesex County, NJ
He had rosy barbs and a betta. He said they were gasping at the top of the tank. Isn't that usually lack of oxygen or bad water quality? It was 17 liters (4 gallons or so?)
vaygirl is offline   Reply With Quote
Old 06-12-2010, 04:35 PM   #4 
Oldfishlady
Member
 
Join Date: Mar 2010
Location: USA
That would be my guess as well Vaygirl, 4g is not big enough to support the oxygen needs or swimming needs of that species IMO, water quality can crash pretty fast with that stocking...
Oldfishlady is offline   Reply With Quote
Old 06-12-2010, 05:07 PM   #5 
Welsh
Member
 
Welsh's Avatar
 
Join Date: Apr 2010
Location: South Wales, UK
That was both my mother and my first thought, the LFS that sold them too me apparently kept fish for years and I argued with my mother that they wouldnt be suitable but "apparently" they were anyway I added them because I was going to put them in the 12 gall today and didnt want to hurt my mothers feelings but by the time I got round to it 3 had died

& im a she for the record vaygirl =)
Welsh is offline   Reply With Quote
Old 06-12-2010, 06:09 PM   #6 
vaygirl
Member
 
vaygirl's Avatar
 
Join Date: Sep 2009
Location: Middlesex County, NJ
Sorry!!!
vaygirl is offline   Reply With Quote
Old 06-13-2010, 02:05 PM   #7 
Welsh
Member
 
Welsh's Avatar
 
Join Date: Apr 2010
Location: South Wales, UK
Haha, no worries. I just re-read what I said and I sounded quite rude so I apologise :)
Welsh is offline   Reply With Quote
Old 06-13-2010, 02:11 PM   #8 
vaygirl
Member
 
vaygirl's Avatar
 
Join Date: Sep 2009
Location: Middlesex County, NJ
I didn't take it that way at all. :)
vaygirl is offline   Reply With Quote
Old 06-13-2010, 02:49 PM   #9 
secuono
Member
 
secuono's Avatar
 
Join Date: Jan 2010
Location: VA
Did you add water conditioner? Is the water at 73-78F? Did you properly acclimate them to the tank?
secuono is offline   Reply With Quote
Old 06-14-2010, 08:52 AM   #10 
Welsh
Member
 
Welsh's Avatar
 
Join Date: Apr 2010
Location: South Wales, UK
That's good to know, I thought I sounded like a right bitch lol.

Secuono - Yup, I did all that you mentioned.
Welsh is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Heh...We all know what happened. SaylorKennedy Betta Pictures 19 06-05-2010 09:37 AM
What happened? xmasfosho Betta Fish Care 4 03-15-2008 01:40 PM


All times are GMT -5. The time now is 07:02 AM.


Powered by vBulletin® Version 3.7.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.