Betta Fish Care  
Go Back   Betta Fish and Betta Fish Care > Betta Fish Care
Check out the eBook Betta Fish Care Made Easy
betta fish
Reply
 
Thread Tools Search this Thread
Old 08-19-2010, 08:35 PM   #1 
thegameksk
New Member
 
Join Date: Oct 2009
Please read. Never use Algaefix

I had a bad casse of algae. My tank was literally green. My lfs said I should use APIs algaefix. They told me it wouldnt hurt the fish or plants. It said the same thing on the bottle. I used exactly the suggested amount on the bottle. I started to use it. It did nothing to my algae. I wokr up 2 days ago to find 2 catfish dead, 2 algae eaters dead, and one of my bettas dead. I did a full cleaning of my tank after this and stopped using it. The next day I awoke to find my 2 other catfish dead. After this I removed my last betta from the tank. This morning I awoke to find him dead. Never use this stuff it will kill your fish. My question is what do I do about my tank? Im scared to put anything else in the tank.
thegameksk is offline   Reply With Quote
Old 08-19-2010, 08:39 PM   #2 
prettylittlefishy
New Member
 
prettylittlefishy's Avatar
 
Join Date: Aug 2010
Location: East Michigan, US.
I'd take the rest of the fish out and just use elbow grease and scrub it hard.
prettylittlefishy is offline   Reply With Quote
Old 08-19-2010, 08:42 PM   #3 
vilmarisv
Member
 
vilmarisv's Avatar
 
Join Date: Apr 2010
Location: Seattle, WA
Quote:
Originally Posted by thegameksk View Post
I had a bad casse of algae. My tank was literally green. My lfs said I should use APIs algaefix. They told me it wouldnt hurt the fish or plants. It said the same thing on the bottle. I used exactly the suggested amount on the bottle. I started to use it. It did nothing to my algae. I wokr up 2 days ago to find 2 catfish dead, 2 algae eaters dead, and one of my bettas dead. I did a full cleaning of my tank after this and stopped using it. The next day I awoke to find my 2 other catfish dead. After this I removed my last betta from the tank. This morning I awoke to find him dead. Never use this stuff it will kill your fish. My question is what do I do about my tank? Im scared to put anything else in the tank.
That's horrible!
I had the same experience with a medication. My LFS said it would not kill my bacteria and the back of the box also said it.
So a few days later I tested the water out of curiosity and the ammonia was off the roof! Fortunately my fish hadn't been affected yet but I had to redo the entire fish tank.

Check your water parameters and make sure everything is alright, you might have damaged your cycle.
Still, I would start over with a new cycle and then add fish.

If your fish are all dead there's definitely something going on.
vilmarisv is offline   Reply With Quote
Old 08-19-2010, 08:43 PM   #4 
thegameksk
New Member
 
Join Date: Oct 2009
There are no more fish in the tank. That stuff killed them all. The only thing in it now is live plants. I want to get more fish but im worried about outting anything else in it
thegameksk is offline   Reply With Quote
Old 08-20-2010, 08:48 AM   #5 
Kokonoko
New Member
 
Kokonoko's Avatar
 
Join Date: Jul 2010
Location: Kansas
Yea... I personally would start over completely. Empty the tank out, scrub everything down thuroughly, rinse everything off, and restart on the whole cycling shabamb again. =( I'm really sorry to hear this happened!

Prittylittlefish said, elbow grease time.

PS: Imo, I'd be giveing some "what-for" to the people who sold me it, asking them to please put some in thier fish tanks as an example!
Kokonoko is offline   Reply With Quote
Old 08-20-2010, 08:15 PM   #6 
thegameksk
New Member
 
Join Date: Oct 2009
Do you think I should get rid of the plants? Could whatever killed the fish still be on the plants and possibly kill more fish??
thegameksk is offline   Reply With Quote
Old 08-20-2010, 09:36 PM   #7 
vaygirl
Member
 
vaygirl's Avatar
 
Join Date: Sep 2009
Location: Middlesex County, NJ
I'd get rid of the plants too, just in case.

I just googled Algaefix and killing fish and found you're not the only one this happened to. :(

Last edited by vaygirl; 08-20-2010 at 09:38 PM.
vaygirl is offline   Reply With Quote
Old 08-20-2010, 09:49 PM   #8 
MrVampire181
Member
 
MrVampire181's Avatar
 
Join Date: May 2009
Location: Colorado
Anything API (except for Stress Coat, Stress Zyme, Aquarium Salt, and BettaFix all of which I use) is bad for bettas.
MrVampire181 is offline   Reply With Quote
Old 08-20-2010, 10:31 PM   #9 
thegameksk
New Member
 
Join Date: Oct 2009
So how do I clean the tank? After the first few fish died I scrubbed it with hot water. What else can I use that wont harm any new fish I purchase?

Also can a mod put this information about Algaefix into a sticky? I dont want this happening to anyone else.
thegameksk is offline   Reply With Quote
Old 08-20-2010, 10:59 PM   #10 
vaygirl
Member
 
vaygirl's Avatar
 
Join Date: Sep 2009
Location: Middlesex County, NJ
Good question. I'd think hot water would do the trick but obviously you've done that. Maybe hot water and then let it sit out in the sun for a day or two, then more hot water. I've heard of people using vinegar. You could try that. Just make sure you rinse really, really well. I know you're probably leery of using anything on it. :/
vaygirl is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Algaefix and Cycle glassmouse Betta Fish Care 4 03-21-2010 10:59 PM
If u dont read "my little beta" read this... Shawtee Betta Fish Care 8 08-17-2009 11:54 PM


All times are GMT -5. The time now is 01:54 PM.


Powered by vBulletin® Version 3.7.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.