Betta Fish Care  
Go Back   Betta Fish and Betta Fish Care > Betta Fish Bowls, Habitats, and Accessories
Check out the eBook Betta Fish Care Made Easy
betta fish
Reply
 
Thread Tools Search this Thread
Old 11-27-2010, 09:06 PM   #1 
blake711
New Member
 
blake711's Avatar
 
Join Date: Oct 2010
newly cycled tank has funk growing in it.

My tank has been showing 7.8ph - 0ppm Ammonia - 0ppm Nitrite and 5ppm Nitrate for the last week and half without change. I noticed today that it now has some kind of funky fungus or something growing on the decorations, plants and on the filter outlet. Also my fish seems to be a bit lethargic the last day or so. Any help is appreciated.


Also hopefully this isn't my issue but do I need carbon filter in my tank? I just realized its been in since it was new about a month and a half ago. Should I change it or just remove it. Thanks.
Attached Images
   
blake711 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Little bubbles still forming in newly setup tank...(pics) brancasterr Betta Fish Care 4 04-16-2010 08:21 AM


All times are GMT -5. The time now is 02:57 PM.


Powered by vBulletin® Version 3.7.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.