Betta Fish Care  
Go Back   Betta Fish and Betta Fish Care > Betta Fish Bowls, Habitats, and Accessories
Check out the eBook Betta Fish Care Made Easy
betta fish
Reply
 
Thread Tools Search this Thread
Old 01-30-2011, 12:41 PM   #1 
JLovesBettas
New Member
 
Join Date: Nov 2010
Dead Filter

So I was running back and forth from my room and when I come in again I realize my filter had stopped. The filter had drained all the water from it and it was trying to run without any water. So I filled it up and found that the tube wasn't totally in so I pushed it in and it wouldn't start. I unplugged it and plugged it back in and it would not start. The past week it has been making this sputtering noise like it is trying really hard to get water up. I didn't think anything of it until now. I tried again this morning and nothing. What would be great is any tips on fixing it. But I doubt there is anything I could do to revive it, so what do I do now? How do I go about putting in a new filter, and what do I do until I can get a new filter? Help is most appreciated.
JLovesBettas is offline   Reply With Quote
Old 01-30-2011, 12:46 PM   #2 
ChicagoPete
Member
 
ChicagoPete's Avatar
 
Join Date: Dec 2010
Location: Northern Chicago Suburbs.
Did you try taking out the tube then giggle up and down and spin the fan blade a few times? The blade sometimes can get calcium buildup and get stuck.
ChicagoPete is offline   Reply With Quote
Old 01-30-2011, 12:49 PM   #3 
Oldfishlady
Member
 
Join Date: Mar 2010
Location: USA
When I have filters that stop...I tear them apart to get to the impeller area..sometimes this can be bound up by something....a snail, gravel, hair, plant material....anything......
You have to be careful and not let them run dry...this can burn them up

If you still have the owner manual I would look through the trouble shooting area...if you don't have it you can usually find information on it on their website and with some you can even get replacement parts

When I tear them apart to work on them I will give them a good cleaning with vinegar for any mineral deposit buildup

I work on mine all the time and some I have had for over 20 years and still work the same as when I got them.....
Oldfishlady is offline   Reply With Quote
Old 01-31-2011, 07:40 PM   #4 
JLovesBettas
New Member
 
Join Date: Nov 2010
Okay well I got down to the impeller and there was nothing there. I am pretty sure it just burnt out because there wasn't any water in it. I will try to find the trouble shooting instructions. But I am wondering how I should go about switching the filter is there a certain way that can help keep most of the cycle bacteria?
JLovesBettas is offline   Reply With Quote
Old 02-02-2011, 05:40 PM   #5 
JLovesBettas
New Member
 
Join Date: Nov 2010
Anyone?
JLovesBettas is offline   Reply With Quote
Old 02-02-2011, 05:48 PM   #6 
Oldfishlady
Member
 
Join Date: Mar 2010
Location: USA
With a new filter-cut the sponge part off the old filter media and add to the new filter media if this is a different type of filter...if the same type of filter just use the old filter media with the beneficial bacteria....however, if the filter media has been without oxygenated water for over 6 hours the beneficial bacteria is most likely dead and you will have to start over...if this is a mature tank....it shouldn't take more than a week or so the get a good colony on the filter media....
Oldfishlady is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
dead shinybetta Betta Chat 11 08-07-2010 04:05 PM
2 for 2 (dead) my dead bettas Betta Fish Care 34 05-15-2010 09:57 AM


All times are GMT -5. The time now is 10:18 AM.


Powered by vBulletin® Version 3.7.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.