Betta Fish Care  
Go Back   Betta Fish and Betta Fish Care > Betta Fish Bowls, Habitats, and Accessories
Check out the eBook Betta Fish Care Made Easy
betta fish
Reply
 
Thread Tools Search this Thread
Old 04-22-2011, 04:22 PM   #1 
CyerRyn
Member
 
CyerRyn's Avatar
 
Join Date: Apr 2011
Location: FDL, WI
Filter issues

This is the first time I've ever set up a filter, and these ones are used. I'm not quite sure what it's suppose to sound like, but every time I plug it in it growls at me. It doesn't spurt out any water. (I have a whisper 10 and a Top-fin 10 that I'm trying to get to work) What am I doing wrong?
CyerRyn is offline   Reply With Quote
Old 04-22-2011, 04:26 PM   #2 
roypattonphoto
Member
 
Join Date: Mar 2011
Location: Oakland CA
Some filters require u to pour a little water in he top of the filter to help with the moving of the water....
roypattonphoto is offline   Reply With Quote
Old 04-22-2011, 04:28 PM   #3 
CyerRyn
Member
 
CyerRyn's Avatar
 
Join Date: Apr 2011
Location: FDL, WI
I tried that, they both still growl at me. Am I suppose to like.. overflow it?
CyerRyn is offline   Reply With Quote
Old 04-22-2011, 04:45 PM   #4 
roypattonphoto
Member
 
Join Date: Mar 2011
Location: Oakland CA
Nah u shouldn't have to.. put water into it all the way up.. if it doesn't push water through then,means the pump is malfunctioning and u need to take it bac.. a lot of times the gears wil grind off on the wheel near the paddles that push the water .. and that's growling sound
roypattonphoto is offline   Reply With Quote
Old 04-22-2011, 04:47 PM   #5 
roypattonphoto
Member
 
Join Date: Mar 2011
Location: Oakland CA
Also if the input has multi section pipe make sure all sections are underwater .. any exposed section if it oesnt couple right could hider the suction process
roypattonphoto is offline   Reply With Quote
Old 04-22-2011, 04:49 PM   #6 
CyerRyn
Member
 
CyerRyn's Avatar
 
Join Date: Apr 2011
Location: FDL, WI
Well these two filters are used, they've been in storage a while and I was hoping I'd be able to spare them to avoid yet another thing I'd need to buy so taking them back is an impossibility. :P I'll try cleaning them up a bit more and add some more water. I have the water in the tank about 1 1/2 inch from the top so I'll see if that's the problem.
CyerRyn is offline   Reply With Quote
Old 04-22-2011, 05:02 PM   #7 
roypattonphoto
Member
 
Join Date: Mar 2011
Location: Oakland CA
Another thing to look at if u can see the paddles pull off the paddle see if the rubber is still on the top of the drive.. could be worn off .. if that's the ase u might be able to use some tape or something to replace the rubber.. but for ome reason ur just not creating the suction needed
roypattonphoto is offline   Reply With Quote
Old 04-22-2011, 05:06 PM   #8 
CyerRyn
Member
 
CyerRyn's Avatar
 
Join Date: Apr 2011
Location: FDL, WI
I poured some more water in it and it started working! Took it 30 seconds to go though but it's functioning. Yay! Thx for all your help, hope its the same issue with the 2nd filter cuz now I know how these ones work.
CyerRyn is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Filter Issues? FlareFlareFlare Betta Fish Bowls, Habitats, and Accessories 1 01-09-2011 12:59 PM
Filter issues... firefly0101 Betta Fish Bowls, Habitats, and Accessories 2 09-21-2010 06:14 PM
Anyone else have issues with having their betta like the intake filter? Hankbetta Betta Fish Care 8 03-27-2010 03:27 PM


All times are GMT -5. The time now is 07:50 PM.


Powered by vBulletin® Version 3.7.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.