Betta Fish Care  
Go Back   Betta Fish and Betta Fish Care > Betta Fish Bowls, Habitats, and Accessories
Check out the eBook Betta Fish Care Made Easy
betta fish
Reply
 
Thread Tools Search this Thread
Old 05-27-2011, 09:12 AM   #11 
nowzem
Member
 
nowzem's Avatar
 
Join Date: Apr 2011
Thanks! Love your 'ancient' god betta names BTW!
nowzem is offline   Reply With Quote
Old 05-27-2011, 09:24 AM   #12 
fishman12
Member
 
fishman12's Avatar
 
Join Date: Sep 2010
Location: ........
yuck
fishman12 is offline   Reply With Quote
Old 05-27-2011, 01:06 PM   #13 
SashimiBetta
New Member
 
SashimiBetta's Avatar
 
Join Date: May 2011
Location: Fish Bowl. (:
I had the same problem. I just replaced the suction cups - Cleaned them thoroughly and I hadn't seen them since - But, I can't say this will work 100% for everyone.
SashimiBetta is offline   Reply With Quote
Old 05-27-2011, 10:07 PM   #14 
Thunderloon
Member
 
Join Date: Feb 2011
Throw out the suction cups and buy new ones.
Thunderloon is offline   Reply With Quote
Old 05-28-2011, 12:45 AM   #15 
PewPewPew
Member
 
Join Date: Nov 2010
Haha, I agree, if you can. It might be hard to do.

Thats for serious nasty stuff. Take a clean tooth brush and GET IT.

And/or nuke it with salt at 3-6tsp/gallon. HAH. (remove the heater first and treat in a different place to not kill the cycle)

I agree that sapro wont grow on it. It probably likes the heat from the heater, hah.
PewPewPew is offline   Reply With Quote
Old 05-28-2011, 12:51 AM   #16 
dramaqueen
Banned
 
Join Date: Jul 2008
Location: Central Texas
Eeeuuuwww!! lol I wouldn't want to touch it, either!
dramaqueen is offline   Reply With Quote
Old 05-28-2011, 12:55 AM   #17 
nowzem
Member
 
nowzem's Avatar
 
Join Date: Apr 2011
There's a fungal sapro. Not the bacteria. But it usually needs some kinda dead matter to feed on...its def some kind of mold though.

I dunno...the tank isn't cycled. I noticed its growing on the same type of heater suction cups in my 20g that I'm cycling right now too. I think its already in the water but who knows why its growing on that. :) I'm not sure why replacing the cups is necessary...bleach and hot water should clean those and its already in the water I guess since its in both tanks. Everything is brand new....really weird cuz its not growing on any of my cycled tanks suction cups LOL. I read that water mold is encouraged in poor water conditions and since i've got the tank cycling...that qualifies. I'm not gonna worry about it too much :)
nowzem is offline   Reply With Quote
Old 05-28-2011, 12:56 AM   #18 
nowzem
Member
 
nowzem's Avatar
 
Join Date: Apr 2011
Quote:
Originally Posted by dramaqueen View Post
Eeeuuuwww!! lol I wouldn't want to touch it, either!
I'ma wear gloves hahaha :) I may or may not throw the cups away... we'll see. Should I drain the water from the tanks?
nowzem is offline   Reply With Quote
Old 05-28-2011, 10:25 PM   #19 
tsoto80
Member
 
tsoto80's Avatar
 
Join Date: Nov 2010
Location: Florida
lick it!!! taste like chicken lol jk
tsoto80 is offline   Reply With Quote
Old 05-29-2011, 06:53 PM   #20 
Neil D
Member
 
Neil D's Avatar
 
Join Date: Apr 2011
Location: Hiding from The Mods
^that is positively gross!!!!Try taking off the cups and just kinda "float" the heater, but make sure that its sumberged properly. Clearly the cups are the issue, see if there is another way to hold the heater in place
Neil D is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:48 AM.


Powered by vBulletin® Version 3.7.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.