Betta Fish Care  
Go Back   Betta Fish and Betta Fish Care > The Lounge
Check out the eBook Betta Fish Care Made Easy
betta fish
Reply
 
Thread Tools Search this Thread
Old 03-28-2012, 02:15 PM   #34811 
Tikibirds
Member
 
Tikibirds's Avatar
 
Join Date: May 2011
Location: Warrensburg, NY
Tikibirds is offline   Reply With Quote
Old 03-28-2012, 02:29 PM   #34812 
Wolfie305
Member
 
Wolfie305's Avatar
 
Join Date: Jan 2012
Location: Sagamore Beach, MA
Ugh I hate PetCo. There's a PetSmart at exit 5 (closer to my house) and a PetCo at exit 7. I pass both on my way to school and because I was in PetSmart yesterday, I figured I would go to PetCo today because my remaining goldfish is showing some signs of being ill I think...

Went in and they had nothing I wanted to get. I wanted to get my betta a moss ball and they had them, but they had them in tanks with other fish (unlike PetSmart, which keeps them in a cup) and I don't want to risk infection.

There are literally NO other PetSmarts on my way to school so I went into another PetCo and still nothing >.<
Wolfie305 is offline   Reply With Quote
Old 03-28-2012, 02:32 PM   #34813 
djembekah
Member
 
djembekah's Avatar
 
Join Date: Feb 2012
Location: Washington
i want moss balls, but i dont have a petco or petsmart nearby. i didn't even notice moss balls at petco, but i saw the ones at petsmart in the cups. i totally want one. might order online buuuuuuut. hm. cannot decide.
djembekah is offline   Reply With Quote
Old 03-28-2012, 03:34 PM   #34814 
Tikibirds
Member
 
Tikibirds's Avatar
 
Join Date: May 2011
Location: Warrensburg, NY
The only plants i see at petco are not even aquatic and usually dying
Tikibirds is offline   Reply With Quote
Old 03-28-2012, 03:45 PM   #34815 
djembekah
Member
 
djembekah's Avatar
 
Join Date: Feb 2012
Location: Washington
yeah i saw a rack of "aquatic plants" at petco, but they were in plastic tubes, and didn't even look wet. They had some potted aquatic plants (i think) too, in a tank. but i didn't recognize any names.
djembekah is offline   Reply With Quote
Old 03-28-2012, 04:01 PM   #34816 
Silverfang
Member
 
Silverfang's Avatar
 
Join Date: Mar 2011
Location: Newfoundland
I just watched my betta attack and bite the tail off one of my shrimp. IT's still twitching and spasming wildly, I don't know what to do with it.

Gonna put the rest of the shrimp in my sorority, and hope they don't get eaten there either.
Silverfang is offline   Reply With Quote
Old 03-28-2012, 04:12 PM   #34817 
Amphibianite
Member
 
Amphibianite's Avatar
 
Join Date: Aug 2011
Location: Central Oregon
I have FRY lots and lots of Fry. They are already free swimming O_o. Amazing. So my MG pair has worked out wonderfully. I am wondering if they mated a few times on different days because of the fact I should just be having eggs hatch today not already tons of free swimming.
well back to serious cleaning. Moving my goldfish and rosey minnow tank out to the sun room to give me more room as well.
Amphibianite is offline   Reply With Quote
Old 03-28-2012, 04:23 PM   #34818 
SwaggDaddy
New Member
 
SwaggDaddy's Avatar
 
Join Date: Mar 2012
do i need a air filter in a 10 gelone tank
SwaggDaddy is offline   Reply With Quote
Old 03-28-2012, 04:35 PM   #34819 
MaisyDawgThirteen
Member
 
MaisyDawgThirteen's Avatar
 
Join Date: Dec 2011
Location: Canada
Quote:
Originally Posted by Sakura8 View Post

Like the new tag, Maisy. XD
IKR? xD

Quote:
Originally Posted by xjenuhfur View Post
Also, was that video from earlier taken down?
Quote:
Originally Posted by Sakura8 View Post
I dunno. When I clicked on the link a while ago, nothing came up.
Quote:
Originally Posted by xjenuhfur View Post
Yes yes the sorority one. I went back to check comments and it wasn't there.
I went to my youtube account history, and the video was made private. xD
MaisyDawgThirteen is offline   Reply With Quote
Old 03-28-2012, 04:38 PM   #34820 
xjenuhfur
Member
 
xjenuhfur's Avatar
 
Join Date: Jan 2012
Location: SoFla
Yay for lots of fry Amph! :D

I got my computer working finally. My Norton was being a butt face, the only fix was to completely uninstall and reinstall. -__- I had to do some serious scanning for malware and whatnot, but it seems to have come up empty handed. I've been on my ipad for the past few days posting. Its not horrid on an ipad, but its annoying with links, and the autocorrect. >8(
xjenuhfur is offline   Reply With Quote
Reply

Tags
0_o, banana !!, bettathanyou, cornucopia=not yummy, eat the cheese, eyeballs!!!!! 0.o"o.0, i started a trend - maisy, like a thread in a thread, tag bombed!, tag! you're it!, taggy mctaggerson, taggy mctaggerson ii, that is dobby's cheese, throw the cheese

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:07 PM.


Powered by vBulletin® Version 3.7.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.