Betta Fish Care  
Go Back   Betta Fish and Betta Fish Care > Betta Fish Bowls, Habitats, and Accessories
Check out the eBook Betta Fish Care Made Easy
betta fish
Reply
 
Thread Tools Search this Thread
Old 12-04-2011, 06:37 PM   #1 
Jodah
Member
 
Jodah's Avatar
 
Join Date: Nov 2011
Location: CT
Angry Tired of the cloudyness.

So, as i've mentioned here and there a while back, it's been approx 8 days since my first pwc, and the tank has been cloudy ever since. Did another pwc about 3 days ago now, no change. I use sand substrate, whisper 10i filter baffled using sponge in the intake, and aqueon 50w heater set at 79*. There are 3 silk plants and a diy cave using pvc pipe, aquarium silicone, and more sand.

I know people have said it's a bacteria bloom, I doubt it, if it was, it would have cleared up by now. I don't have a phosphate test kit, nor a nitrites/nitrates test kit (will soon though)

So, any other ideas?
Jodah is offline   Reply With Quote
Old 12-04-2011, 08:15 PM   #2 
bastage
Member
 
bastage's Avatar
 
Join Date: Oct 2011
Location: Boise ID
picture maybe?
bastage is offline   Reply With Quote
Old 12-04-2011, 08:28 PM   #3 
Jodah
Member
 
Jodah's Avatar
 
Join Date: Nov 2011
Location: CT
Hasn't changed since I posted it in the "pics of tanks" thread. So, here it is.



And to show just how cloudy it actually is:


I literally just changed the filter cartridge maybe 20 minutes ago. May have to change the sponge that I baffled the intake with.
Jodah is offline   Reply With Quote
Old 12-04-2011, 08:31 PM   #4 
Fasht
Member
 
Fasht's Avatar
 
Join Date: Oct 2011
Location: pennsylvania
just give it time for the sand to settle, mine took about 2 weeks to get cleared or maybe your filter flow is too strong that it's disturbing the sand

Off topic: He looks just like my Urchin!
Fasht is offline   Reply With Quote
Old 12-04-2011, 08:54 PM   #5 
Jodah
Member
 
Jodah's Avatar
 
Join Date: Nov 2011
Location: CT
The thing that gets me is everything was clear until i added the silk plants. And it's petco sand, so it's not very fine at all. Although, even now after changing the filter cartridge, there's no more "scum" on the top. So, we'll see.

Yeah, dude was too cool looking for me to pass up. I love the blue/white mixed in. I think i got an emo betta though. He'll flare at the mirror once, then stop. lol.
Jodah is offline   Reply With Quote
Old 12-04-2011, 09:06 PM   #6 
bastage
Member
 
bastage's Avatar
 
Join Date: Oct 2011
Location: Boise ID
if the problem started when adding the plants then have you tried pulling them out?

My black petco sand seemed to never settle.. Eventually I just did a few water changes & it was clear. Also important to make sure not to disturb the sand when doing the change.
bastage is offline   Reply With Quote
Old 12-04-2011, 09:13 PM   #7 
EvilVOG
Member
 
EvilVOG's Avatar
 
Join Date: Nov 2011
Location: Detroit, Mi
have you tried a water clarifier chem from a lps?
EvilVOG is offline   Reply With Quote
Old 12-05-2011, 10:02 AM   #8 
Jodah
Member
 
Jodah's Avatar
 
Join Date: Nov 2011
Location: CT
'm sorely tempted to pull them out. Idk, I'll give it another couple days seeing as I changed the cartridge. But I'm thinking the plants will be coming out.

You shouldn't use a water classifiers. In my opinion they merely hide and underlying problem.
Jodah is offline   Reply With Quote
Old 12-05-2011, 11:08 AM   #9 
ANHEL123
Member
 
Join Date: Jul 2010
Location: Philadelphia
How about if you will try to do more water changes?
ANHEL123 is offline   Reply With Quote
Old 12-05-2011, 02:05 PM   #10 
bettafish15
Member
 
bettafish15's Avatar
 
Join Date: Oct 2010
Location: British Columbia, Canada
It could be because you changed the filter media... the tank was trying to cycle but it keeps getting disrupted perhaps.
bettafish15 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting...tired of fishes... Bresn The Lounge 5 10-13-2011 05:24 PM
Mysterious Overnight Cloudyness super100sap Betta Fish Care 4 12-01-2010 11:05 PM
never gets tired cindylou Betta Pictures 5 11-29-2009 12:28 PM


All times are GMT -5. The time now is 11:15 AM.


Powered by vBulletin® Version 3.7.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.