Betta Fish Care  
Go Back   Betta Fish and Betta Fish Care > Betta Fish Compatibility
Check out the eBook Betta Fish Care Made Easy
betta fish
Reply
 
Thread Tools Search this Thread
Old 01-14-2012, 09:53 PM   #1 
Laki
Member
 
Laki's Avatar
 
Join Date: Aug 2011
Location: St. John's NL
why did my ghosties die?!

All of my ghost shrimp are dead. I went to work they were swimming around, eating, tickling their feet. Now they're dead. Can't find Lakitu either.

edit: Lakitu I found gasping for breath and very still. Very clamped. I rushed him to a Q tank without salt bc I wasn't sure about the salt we have. I'm actually quite upset right now.
I cleaned everything last night! Can the new plants be too much?? Sucked the good nutrients out of the tank? I'm going to have the water tested Monday and I'm returning the shrimp and asking about returning plants IF you guys think it might be an issue.
I hope Laki doesn't die! GUYS!!!! Vibes!

Last edited by Laki; 01-14-2012 at 10:03 PM.
Laki is offline   Reply With Quote
Old 01-14-2012, 11:36 PM   #2 
Sakura8
Member
 
Join Date: May 2011
Location: Elk Grove, California
I can't imagine why the plants would cause a tank crash. :( I'm so sorry about your ghosties and gosh, I hope Lakitu pulls through!

Are the ghosties new? Maybe they caused an ammonia spike.
Sakura8 is offline   Reply With Quote
Old 01-14-2012, 11:59 PM   #3 
BETTACHKALOVE
Member
 
Join Date: Nov 2010
I know it crazy question but are you sure that you didn't forget to use water conditioner?
How is Laki doing?
BETTACHKALOVE is offline   Reply With Quote
Old 01-15-2012, 07:48 AM   #4 
Laki
Member
 
Laki's Avatar
 
Join Date: Aug 2011
Location: St. John's NL
I put conditioner in, in fact I added a bit extra because of all the new things. I was wondering about the plants myself, the reason I got them was to benefit the tank! I doubt that ammonia was involved because Hornwort sucks it up like a vacuum I read!
I was watching the temperature (because of the new heater) and it stayed very consistent.
On another forum (not as active so I'm surprised I even got a reply) the aquarium expert told me to clean everything and return Lakitu to it.. But I'm too afraid to do that! She thinks the sudden gravel change might have screwed up the bacteria balance? I don't filter the tank so I don't know. I'm going to set up the 1g with the betta therm and see how he is. He survived the night at least :/
Yes, the ghost shrimp were new. I spent like 53$ the night before on all this new stuff (gravel, heater, shrimp, thermometer, plants)
It was too late last night to clean the tank and I wasn't sure how to keep a sample of water for the test.
I will call PetSmart when they open to see if they want the shrimp back. I want cherry shrimp (which are totally freshwater) but they don't have any. I don't think my freshwater tank killed the shrimp though (they can survive non-brackish) .. right?

Thanks for the replies :)
Laki is offline   Reply With Quote
Old 01-15-2012, 10:06 AM   #5 
Sakura8
Member
 
Join Date: May 2011
Location: Elk Grove, California
If you don't filter the tank, then yeah, you probably did have a lot of bacteria in the gravel. That might be it. If that's the case, I would wait a week or more for the bacteria to build up again OR put Lakitu back in and do frequent water changes.

If they're ghost shrimp, they should be freshwater and okay in our tanks.
Sakura8 is offline   Reply With Quote
Old 01-15-2012, 04:12 PM   #6 
Laki
Member
 
Laki's Avatar
 
Join Date: Aug 2011
Location: St. John's NL
I don't have a filter, no. . . I'll touch base tomorrw after I finds out what went wrong. I currently have Lakitu in a 1g with some old gravel and an old silk plant and the 2 nano moss balls. He's been sleeping on top of an IAL all day.
Laki is offline   Reply With Quote
Old 01-15-2012, 05:25 PM   #7 
fishy friend2
Member
 
fishy friend2's Avatar
 
Join Date: Aug 2011
How did you acclimate the fish? And did you use soap to clean the aquarium
fishy friend2 is offline   Reply With Quote
Old 01-15-2012, 05:42 PM   #8 
fishman12
Member
 
fishman12's Avatar
 
Join Date: Sep 2010
Location: ........
The plants were most likely carrying a disease that caused the deaths. As annoying as it is, plants have to be QTed before being introduced.
fishman12 is offline   Reply With Quote
Old 01-15-2012, 06:25 PM   #9 
Laki
Member
 
Laki's Avatar
 
Join Date: Aug 2011
Location: St. John's NL
goodness no I didn't use soap!! I always only use hot water and a clean fish only sponge.
The plants have a good rep coming from the store, tanks are clean and plants look good. I guess the period between now and next week will acclimate them- I hope it wasn't disease! How would we ever know? I hope some questions will be answered tomorrow, I'll see about Safe Start too, to see that this doesn't happen again :/
Laki is offline   Reply With Quote
Old 01-15-2012, 06:42 PM   #10 
fishman12
Member
 
fishman12's Avatar
 
Join Date: Sep 2010
Location: ........
Yep. Any new symtons in your betta?
fishman12 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
my ghosties have BABIES!!! Echo Betta Fish Compatibility 5 10-31-2011 08:33 PM
Ghosties! HayrideHaunter The Lounge 15 07-19-2011 06:32 PM
All my ghosties died, what did I do wrong? Littlebittyfish Betta Fish Compatibility 8 03-23-2011 09:27 PM
Ghosties DormDrax Betta Fish Compatibility 5 03-09-2011 08:21 PM


All times are GMT -5. The time now is 09:43 AM.


Powered by vBulletin® Version 3.7.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.