Betta Fish Care  
Go Back   Betta Fish and Betta Fish Care > Betta Fish Bowls, Habitats, and Accessories
Check out the eBook Betta Fish Care Made Easy
betta fish
Reply
 
Thread Tools Search this Thread
Old 03-28-2012, 07:34 PM   #1 
Trochophore
New Member
 
Join Date: Mar 2012
My filter is really frustrating me D:

I just set up my filter that came with the Marineland Eclipse 3g, and the first thing I noticed is that it made a buzzing sound that would buzz for a few seconds, go away, and come back again. I didn't really mind it at first, but then I noticed that it was interfering with my heater!

I use the Elite 25W heater and I noticed that whenever the filter was making its buzzing noises, the pilot light on my heater was flickering in sync with the buzzing.

I have taken out the filter, took it apart, cleaned it, added more water... Nothing seems to be helping. Anyone have any other ideas?
Trochophore is offline   Reply With Quote
Old 03-28-2012, 08:03 PM   #2 
ao
TFK Moderator
 
ao's Avatar
 
Join Date: Feb 2012
Location: NYC
could be your power source. turn the filter off and see if the heater still flickers....
ao is offline   Reply With Quote
Old 03-29-2012, 12:46 AM   #3 
Trochophore
New Member
 
Join Date: Mar 2012
I fiddled around with it for a bit trying different power combinations (filter only, heater only, different sockets since I used to have them both on the same extension cord...) seems like the problem definitely is the filter as it makes the sounds even without the heater, and it seems like it doesn't have to do with the power as it still buzzed when they were in different sockets.

However, I found that when I unplugged the filter and started it up again, the buzzing would go away for about a minute before it returned...
Trochophore is offline   Reply With Quote
Old 03-29-2012, 01:16 AM   #4 
ao
TFK Moderator
 
ao's Avatar
 
Join Date: Feb 2012
Location: NYC
hmmm, go for a refund...? It should have some kind of warranty on it right?
ao is offline   Reply With Quote
Old 03-29-2012, 01:40 AM   #5 
MysticMuffin
New Member
 
Join Date: Mar 2012
I remember when I was setting up a tank for my mom, the filter also made a weird sound. Apparently the cartridges weren't pushed all the way down when I had filled it with water (made them move outta place/pop up a little), so once I pushed them back down, the sound had stopped. I don't know if this is the same issue with you though :s
MysticMuffin is offline   Reply With Quote
Old 03-29-2012, 10:48 PM   #6 
Trochophore
New Member
 
Join Date: Mar 2012
Hmm seems like the buzzing went away magically while I was at school today. Thanks for all the suggestions though! Greatly appreciated :D
Trochophore is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
So frustrating, ugh. thatgirl Betta Chat 5 04-12-2011 10:47 PM
This is getting frustrating.... DragonFish Betta Fish Diseases and Emergencies 20 01-20-2010 05:41 PM
2.5 minibow filter tore tailfin, need advice putting in Red Sea filter ASAP KristiLee Betta Fish Bowls, Habitats, and Accessories 1 01-09-2010 07:58 PM
Ugh, so frustrating. :( SaylorKennedy Betta Fish Care 12 11-29-2009 05:43 PM


All times are GMT -5. The time now is 09:36 PM.


Powered by vBulletin® Version 3.7.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.