Odd "Urgent Chrome Update" Scam - Betta Fish and Betta Fish Care
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 12-11-2016, 07:57 PM Thread Starter
Member
 
ThatFishThough's Avatar
 
Join Date: Jan 2016
Location: North Dakota
Posts: 3,462
Aquarium
Odd "Urgent Chrome Update" Scam

So, every time I click "Go Advanced" or go to a new page of the website, I get a new tab that says "Urgent Chrome Update" with the Chrome symbol, a download button, and nothing else. I haven't clicked on it, and I won't, but I'm concerned that someone is trying to hack into this site or my computer. Every time the page comes up, it is a different URL.

Any ideas on what this is? How do I keep it from popping up? It's getting a bit annoying.

ETA: IT happened again when moving to a new page of Russel's journal. Now that I'm trying to figure out what's causing it, it's started to do it irregularly with seemingly no cause.

The Males~
Lucifer, Gabriel, Titan, King, Finnegan, Fin-again & Ricky.
Lucifer & Gabriel are my only non-rescues...

The Females~
Karma

Last edited by ThatFishThough; 12-11-2016 at 08:03 PM.
ThatFishThough is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 12-11-2016, 09:15 PM
Member
 
Tourmaline's Avatar
 
Join Date: Nov 2015
Location: Mahopac, New York
Posts: 1,984
The same thing happens to me on mobile, this particular website always gives me redirects to scam "virus alert" pages.


Check out my journal - SIP to all of the Bettas I've lost
Tourmaline is offline  
post #3 of 5 (permalink) Old 12-11-2016, 09:29 PM
Administrator
 
Admin_Yungster's Avatar
 
Join Date: Mar 2013
Posts: 1,152
Hey there,

I use Chrome as my primary browser on all my devices/computers and I've yet to encounter this. I would advise you run a malware scan on your computer/device if you continue getting this message. You may also want to clear your browser history to see if this fixes the issue.

Yung
Admin_Yungster is offline  
 
post #4 of 5 (permalink) Old 01-31-2017, 08:32 PM Thread Starter
Member
 
ThatFishThough's Avatar
 
Join Date: Jan 2016
Location: North Dakota
Posts: 3,462
Aquarium
Even after clearing my browser and running a Kaspersky Full Scan I am still encountering this problem, now with added mouseblocks and sound!

The Males~
Lucifer, Gabriel, Titan, King, Finnegan, Fin-again & Ricky.
Lucifer & Gabriel are my only non-rescues...

The Females~
Karma
ThatFishThough is offline  
post #5 of 5 (permalink) Old 01-31-2017, 08:48 PM
Member
 
sabrinah's Avatar
 
Join Date: Jan 2015
Location: California
Posts: 1,148
I haven't had any issues on my laptop yet but every single time I post something to this forum on my mobile I get a message saying the URL can't be found on the server. Being that 'server' is spelled wrong, it seems a little sketchy.

SIP Spitfire, Dyson, and Spike
sabrinah is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Betta Fish and Betta Fish Care forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Growing "Star Moss", "Fissidens", "Flame Moss" Advice Please! Aryia Planted Betta Tanks 9 11-07-2013 11:19 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
Powered by vBadvanced CMPS v3.2.3
For the best viewing experience please update your browser to Google Chrome