Betta Fish Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hi again! So I've went to one of my local aquatic stores if you will. They were very informative and helpful and I trust their advice, but I don't want to bother them too much! Lol

I've been cycling a tank for about a week and a half, the water has since been going down a bit and I have some like fuzzy, stringy algae going on(I'll post the picture). Can someone help if I need to do some maintenance on the tank before I get my betta? Like if I should do a sorta small water change, remove the algae?

On Tuesday(today I'm writing this is sunday) I'm going in to get the water in my tank tested to see If it's good to go. And maybe hopefully get a betta. But I'll have to see first.

And for anyone who is wanting to know, the tank is 5 gallons, I do have real plants in there. Yes I have a heater and keeping the heat around the 25°c mark. I will be getting the pump nozzle closed up more so it isn't circulation as fast.

Thanks!!!! I really appreciate any help coming my way!


Sent from my SM-N975W using Tapatalk
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
What exactly do you mean by "cycling"? Up and running or actual cycling with an Ammonia source?
I believe actual cycling? They told me to run the tank for 2 weeks, I got items from a big box store. One bacteria solution and a water conditioner. They people at the aquatic store informed me that the bacteria wouldn't really do much but I could still add it in. So I did and the conditioner. The they also told me to add the betta food for the ammonia source? So I did a couple of shakes of that in at the beginning.

Sent from my SM-N975W using Tapatalk
 
1 - 3 of 3 Posts
Top