Betta Fish Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
86 Posts
Discussion Starter #1
Today, I got tired of my fake set-up and wanted to give my little betta boy some life in his tank. I bought sand and three live plants, but now the water is really cloudy. I let the filter run on high intensity setting for about half an hour before I put him in and lowered it back down to minimum, but I am still worried about how cloudy it looks.
I rinsed the black and the purple stones and my plants are Cabomba aquatica, Ludwiga sp.Mexico and Hemigraphis alternata. (oh and this is a temporary lamp, my proper tank light is on its way to me)

Is this too much of cloudiness? Do you think it will settle down after a few days? And if it does not, when should I be concerned?
It's probably nothing, but I would hate to do him any wrong or cause him discomfort.
He doesn't seem to mind. He's very explory, especially about his new house he seems to love.

He has about 55% of his original water, I didn't clean the walls so I don't rub off any of the good bacteria.
I put the right amount of Tetra - AquaSafe and Tetra - AquaMin into the water.

Is this okay? Is this normal?
 

Attachments

·
Registered
Joined
·
63 Posts
I really like your set up. I’ve always wanted to try a brightly colored rocks on sand, but I’m too paranoid about them mixing.

Anyway, is that actual sand? If you don’t rinse sand really, really well it will cloud up for awhile when you put it into your tank with water.
 
1 - 2 of 2 Posts
Top