Betta Fish Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
93 Posts
Discussion Starter · #1 ·
Okay so I'm a complete newbie. To aquariums and to plants. Mainly plants. These are the first plants I've ever kept, aquatic or otherwise. They've been in my 10 gallon for about 3 weeks as my tank is cycling. I've had one plant die but the rest have been what I figured was healthy. The plants in this tank are mainly annubias and java ferns along with a moss ball and two 'mystery' plants a local fish store employee sold me assuring me that they'd be okay in my 10 gallon but that he had forgotten the names of them. I have been giving the plants plenty of light. I leave the light on about 24 hours but turn the 'night' light on in the evening. (The lights I'm using are LEDs that come with the marineland 10 gallon aquarium kit). Most of the plants look fine with the exception of 3. One of the annubias has light green speckles on it, one of the java ferns has some brown spots and one of the plants sold to me by the local fish store - has been losing lots of leaves although shows no spots or signs of disease like the other 2. I did use a complete substrate under the gravel to supply iron for the plant roots. I do know some people use co2 for their planted tanks, perhaps that is the issue? Any advice would be greatly appreciated.
Some pictures:
Annubia (1st picture)
unknown plant (2nd picture)
java fern (3rd picture)
 

Attachments

·
Registered
Joined
·
4,896 Posts
What sort of substrate are you using?
The anubias looks like a slight potassium deficiency, the java fern looks like a phosphate deficiency. No clue on the middle one, sometimes new plants will melt off old growth when placed in a tank, as long as it's growing faster than losing leaves I wouldn't worry.
The other possibility is that the LEDs aren't very good. I am/have grown both anubias and java fern under LED before with no problems, but you might want to consider getting a fluorescent light if possible.
 

·
Registered
Joined
·
4,896 Posts
With potassium and phosphate, of course! :)
Any liquid plant fert will cover this for you. Seachem's Flourish is a good brand.
 

·
Registered
Joined
·
4,896 Posts
No problem at all. Remember plants are slow- at best you want to see things not getting worse once you start with the ferts.
 

·
Registered
Joined
·
2,128 Posts
I notice in the bottom pic - you have your java fern's rhizome (roots) buried in the substrate. This plant does much better when the roots are tied to a bit of driftwood or a rock, as they may rot when buried.

Java fern always tends to look a bit manky after moving tanks, and gets brown spots when ready to reproduce (I see yours already has baby plants growing off the longer leaves) so don't worry if it looks a bit like that for a while, it'll pick up under adequate light.

Anubias also does better tied to rock or wood. Both plants are epiphytic (semi-parasitic) meaning they don't grow in substrate but on the branches of other plants.

If you want plants that will feed on the substrate, try some true aquatic stem plants (wisteria, elodea, etc) or swords - swords will need root tabs after a while and can grow huge, but they're great for the water.
 
1 - 7 of 7 Posts
Top