Betta Fish Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Well, I recently bought two whisper 3i filters for my two fish tanks, and I was setting them up and I noticed something curious. They don't whisper. They're actually VERY loud. It might be that the air pump is rattling against my tank lid, but even when I take it off, it's MUCH louder than I expected. I could've just had too high an expectation for how much the filter would actually whisper, but I'm still concerned that, perhaps, there's something wrong with my filters.

Just for reference, I have a 1 gal, and a 1 1/2 gal. I'm planning on getting a bigger tank for my 1 gal fish, but I'm waiting until I move into my college dorm.

Any advice? Thanks!
 

·
Registered
Joined
·
3,214 Posts
Mine does the same thing unless the pump is sitting on cloth. The filter itself is silent but the air pump is what vibrates and is loud.
 

·
Reference Team
Joined
·
7,703 Posts
The Whisper 3i is a poorly designed sponge filter. It does not filter effectively, nor is a great base for the nitrifying bacteria colony. If possible, I would take them back.

If you still want to go with a sponge filter, get a quality item as recommended on this thread.
Sponge Filter tutorial

One Tetra Whisper 10 air pump will drive both sponge filers -- more quietly than the cheap 3i pump.

Optimally you'd want to get them into >2.5g tanks (preferably 5g) with something like this Aquarium Internal IF-20 (if you'd rather not run sponge filters).
 
1 - 3 of 3 Posts
Top